Johnvey.GmailAgent

Gmail Agent API v0.5 Library

Johnvey.GmailAgent Namespace

Provides remote procedure services for Google's Gmail service.

Classes

Class | Description
GmailAdapter | Represents a set of tools used to communicate with the Gmail system.
GmailCertificatePolicy | Provides security certificate validation bypass services.
GmailContact | Represents a Gmail address book contact.
GmailContactCollection | Represents a collection of GmailContact objects.
GmailCookieFactory | Provides Gmail-specific cookie generation services.
GmailSession | Represents an in-use Gmail mailbox account.
GmailSessionCollection | Represents a collection of GmailSession objects.
GmailThread | Represents a Gmail conversation thread summary.
GmailThreadCollection | Represents a collection of GmailThread objects.
Utilities | A collection of auxilliary tools used to deal with Gmail data.

Delegates

Delegate | Description
GmailAdapter.RefreshDelegate | Represents a delegate for the Refresh method.
GmailSession.EventHandler | Default EventHandler for GmailSession events.

Enumerations

Enumeration | Description
GmailAdapter.RequestResponseType | Defines the result of a Gmail request.
GmailAdapter.ThreadFetchType | Defines the type of threads to retrieve.

Send comments on this topic.

2004 Developed by Johnvey Hwang. Gmail is a registered trademark of Google Inc.


GmailAdapter Class

Represents a set of tools used to communicate with the Gmail system.

For a list of all members of this type, see GmailAdapter Members.

System.Object
GmailAdapter

public class GmailAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

GmailAdapter Members | Johnvey.GmailAgent Namespace


GmailAdapter Members

GmailAdapter overview

Public Static Fields

GMAIL_HOST_URL | Defines the base URL for Gmail requests.
GOOGLE_LOGIN_REFERRER_URL | Defines the URL to fake as the GOOGLE_LOGIN_URL's referrer. (I don't know if Google is checking this, but it can't hurt.)
GOOGLE_LOGIN_URL | Defines the URL to POST Google Accounts login information.

Public Instance Constructors

GmailAdapter Constructor Initializes a new instance of the GmailAdapter class.

Public Instance Properties

JsVersion | Gets or sets the Gmail JS engine version.
LastErrorMessage | Gets the last error message generated by the GmailAdapter methods. Will be null if there are no errors.
RawDataPackResponse | Gets the raw HTML content returned from a DataPack request.
RawHomeFrameResponse | Gets the raw HTML content returned from the Gmail base launch request.
RawLoginResponse | Gets the raw HTML content returned from the Google Accounts login request.
ThreadFetchMode | Gets or sets the GmailAdapter.ThreadFetchType for the adapter. The default is Inbox.

Public Instance Methods

AddContact | Adds a contact into the address book. Emails that already exist will be updated with the new information.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetContacts | Retrieves all the contacts in the user's Gmail address book.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Queries Gmail to get latest mailbox information.
RefreshDataPack | Requests the auto-refresh DataPack.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter Constructor

Initializes a new instance of the GmailAdapter class.

public GmailAdapter();

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter Fields

The fields of the GmailAdapter class are listed below. For a complete list of GmailAdapter class members, see the GmailAdapter Members topic.

Public Static Fields

GMAIL_HOST_URL | Defines the base URL for Gmail requests.
GOOGLE_LOGIN_REFERRER_URL | Defines the URL to fake as the GOOGLE_LOGIN_URL's referrer. (I don't know if Google is checking this, but it can't hurt.)
GOOGLE_LOGIN_URL | Defines the URL to POST Google Accounts login information.

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.GMAIL_HOST_URL Field

Defines the base URL for Gmail requests.

public const string GMAIL_HOST_URL;

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.GOOGLE_LOGIN_REFERRER_URL Field

Defines the URL to fake as the GOOGLE_LOGIN_URL's referrer. (I don't know if Google is checking this, but it can't hurt.)

public const string GOOGLE_LOGIN_REFERRER_URL;

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.GOOGLE_LOGIN_URL Field

Defines the URL to POST Google Accounts login information.

public const string GOOGLE_LOGIN_URL;

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter Properties

The properties of the GmailAdapter class are listed below. For a complete list of GmailAdapter class members, see the GmailAdapter Members topic.

Public Instance Properties

JsVersion | Gets or sets the Gmail JS engine version.
LastErrorMessage | Gets the last error message generated by the GmailAdapter methods. Will be null if there are no errors.
RawDataPackResponse | Gets the raw HTML content returned from a DataPack request.
RawHomeFrameResponse | Gets the raw HTML content returned from the Gmail base launch request.
RawLoginResponse | Gets the raw HTML content returned from the Google Accounts login request.
ThreadFetchMode | Gets or sets the GmailAdapter.ThreadFetchType for the adapter. The default is Inbox.

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.JsVersion Property

Gets or sets the Gmail JS engine version.

public string JsVersion {get; set;}

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.LastErrorMessage Property

Gets the last error message generated by the GmailAdapter methods. Will be null if there are no errors.

public string LastErrorMessage {get;}

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.RawDataPackResponse Property

Gets the raw HTML content returned from a DataPack request.

public string RawDataPackResponse {get;}

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.RawHomeFrameResponse Property

Gets the raw HTML content returned from the Gmail base launch request.

public string RawHomeFrameResponse {get;}

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.RawLoginResponse Property

Gets the raw HTML content returned from the Google Accounts login request.

public string RawLoginResponse {get;}

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.ThreadFetchMode Property

Gets or sets the GmailAdapter.ThreadFetchType for the adapter. The default is Inbox.

public GmailAdapter.ThreadFetchType ThreadFetchMode {get; set;}

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter Methods

The methods of the GmailAdapter class are listed below. For a complete list of GmailAdapter class members, see the GmailAdapter Members topic.

Public Instance Methods

AddContact | Adds a contact into the address book. Emails that already exist will be updated with the new information.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetContacts | Retrieves all the contacts in the user's Gmail address book.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Queries Gmail to get latest mailbox information.
RefreshDataPack | Requests the auto-refresh DataPack.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.AddContact Method

Adds a contact into the address book. Emails that already exist will be updated with the new information.

public bool AddContact(
string name,
string email,
string notes
);

Parameters

name
Contact display name.
email
Contact email address.
notes
Optional notes.

Return Value

True if Gmail accepted the command; false otherwise.

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.GetContacts Method

Retrieves all the contacts in the user's Gmail address book.

public GmailContactCollection GetContacts();

Return Value

A GmailContactCollection of contacts in address book.

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.Refresh Method

Queries Gmail to get latest mailbox information.

public RequestResponseType Refresh(
GmailSession session
);

Parameters

session
The GmailSession object to query.

Return Value

The GmailAdapter.RequestResponseType.

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.RefreshDataPack Method

Requests the auto-refresh DataPack.

public bool RefreshDataPack(
bool forceRefresh
);

Parameters

forceRefresh
DEBUG: Indicates whether to pass an old timestamp, which forces Gmail to resend a full DataPack.

Remarks

If the threadlist timestamp has not changed, Gmail will only send a short DataPack.

See Also

GmailAdapter Class | Johnvey.GmailAgent Namespace


GmailAdapter.RefreshDelegate Delegate

Represents a delegate for the Refresh method.

public delegate GmailAdapter+RequestResponseType GmailAdapter.RefreshDelegate(
GmailSession session
);

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

Johnvey.GmailAgent Namespace


GmailAdapter.RequestResponseType Enumeration

Defines the result of a Gmail request.

public enum GmailAdapter.RequestResponseType

Members

Member Name | Description
Success | The request was successful.
LoginFailed | The Google Accounts login information did not validate.
RefreshFailed | The DataPack request was not successful.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

Johnvey.GmailAgent Namespace


GmailAdapter.ThreadFetchType Enumeration

Defines the type of threads to retrieve.

public enum GmailAdapter.ThreadFetchType

Members

Member Name | Description
AllUnread | Unread threads (global).
Inbox | Inbox threads (read + unread).

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

Johnvey.GmailAgent Namespace


GmailCertificatePolicy Class

Provides security certificate validation bypass services.

For a list of all members of this type, see GmailCertificatePolicy Members.

System.Object
GmailCertificatePolicy

public class GmailCertificatePolicy : ICertificatePolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

GmailCertificatePolicy Members | Johnvey.GmailAgent Namespace


GmailCertificatePolicy Members

GmailCertificatePolicy overview

Public Instance Constructors

GmailCertificatePolicy Constructor Initializes a new instance of the GmailCertificatePolicy class.

Public Instance Methods

CheckValidationResult | Simulates a certificate verification.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailCertificatePolicy Class | Johnvey.GmailAgent Namespace


GmailCertificatePolicy Constructor

Initializes a new instance of the GmailCertificatePolicy class.

public GmailCertificatePolicy();

See Also

GmailCertificatePolicy Class | Johnvey.GmailAgent Namespace


GmailCertificatePolicy Methods

The methods of the GmailCertificatePolicy class are listed below. For a complete list of GmailCertificatePolicy class members, see the GmailCertificatePolicy Members topic.

Public Instance Methods

CheckValidationResult | Simulates a certificate verification.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailCertificatePolicy Class | Johnvey.GmailAgent Namespace


GmailCertificatePolicy.CheckValidationResult Method

Simulates a certificate verification.

public bool CheckValidationResult(
ServicePoint sp,
X509Certificate cert,
WebRequest req,
int problem
);

Parameters

sp
The associated ServicePoint.
cert
The certificate to examine.
req
The WebRequest to use.
problem
I have no idea.

Return Value

Always returns true.

Implements

ICertificatePolicy.CheckValidationResult

See Also

GmailCertificatePolicy Class | Johnvey.GmailAgent Namespace


GmailContact Class

Represents a Gmail address book contact.

For a list of all members of this type, see GmailContact Members.

System.Object
GmailContact

public class GmailContact

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

GmailContact Members | Johnvey.GmailAgent Namespace


GmailContact Members

GmailContact overview

Public Instance Constructors

GmailContact Overloaded. Initializes a new instance of the GmailContact class.

Public Instance Properties

Email | Gets or sets the contact email address.
EmailUnescaped | Gets or sets the contact email address in HTML unescaped format (I've never noticed a difference with email).
IsFrequentlyMailed | Gets or sets the contact frequently mailed flag.
Name | Gets or sets the contact display name.
Notes | Gets or sets the contact note.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailContact Class | Johnvey.GmailAgent Namespace


GmailContact Constructor

Initializes a new GmailContact class.

Overload List

Initializes a new GmailContact class.

public GmailContact();

Initializes a new GmailContact class with an initial email address and display name.

public GmailContact(string,string);

See Also

GmailContact Class | Johnvey.GmailAgent Namespace


GmailContact Constructor ()

Initializes a new GmailContact class.

public GmailContact();

See Also

GmailContact Class | Johnvey.GmailAgent Namespace | GmailContact Constructor Overload List


GmailContact Constructor (String, String)

Initializes a new GmailContact class with an initial email address and display name.

public GmailContact(
string email,
string name
);

Parameters

email
The contact's email address.
name
The contact's display name.

See Also

GmailContact Class | Johnvey.GmailAgent Namespace | GmailContact Constructor Overload List


GmailContact Properties

The properties of the GmailContact class are listed below. For a complete list of GmailContact class members, see the GmailContact Members topic.

Public Instance Properties

Email | Gets or sets the contact email address.
EmailUnescaped | Gets or sets the contact email address in HTML unescaped format (I've never noticed a difference with email).
IsFrequentlyMailed | Gets or sets the contact frequently mailed flag.
Name | Gets or sets the contact display name.
Notes | Gets or sets the contact note.

See Also

GmailContact Class | Johnvey.GmailAgent Namespace


GmailContact.Email Property

Gets or sets the contact email address.

public string Email {get; set;}

See Also

GmailContact Class | Johnvey.GmailAgent Namespace


GmailContact.EmailUnescaped Property

Gets or sets the contact email address in HTML unescaped format (I've never noticed a difference with email).

public string EmailUnescaped {get; set;}

See Also

GmailContact Class | Johnvey.GmailAgent Namespace


GmailContact.IsFrequentlyMailed Property

Gets or sets the contact frequently mailed flag.

public bool IsFrequentlyMailed {get; set;}

See Also

GmailContact Class | Johnvey.GmailAgent Namespace


GmailContact.Name Property

Gets or sets the contact display name.

public string Name {get; set;}

See Also

GmailContact Class | Johnvey.GmailAgent Namespace


GmailContact.Notes Property

Gets or sets the contact note.

public string Notes {get; set;}

See Also

GmailContact Class | Johnvey.GmailAgent Namespace


GmailContactCollection Class

Represents a collection of GmailContact objects.

For a list of all members of this type, see GmailContactCollection Members.

System.Object
ArrayList
GmailContactCollection

public class GmailContactCollection : ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

GmailContactCollection Members | Johnvey.GmailAgent Namespace


GmailContactCollection Members

GmailContactCollection overview

Public Instance Constructors

GmailContactCollection Constructor Initializes a new instance of the GmailContactCollection class.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add (inherited from ArrayList) | Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailContactCollection Class | Johnvey.GmailAgent Namespace


GmailContactCollection Constructor

Initializes a new instance of the GmailContactCollection class.

public GmailContactCollection();

Remarks

This class currently inherits ArrayList, and therefore is not strongly typed. Ideally it should implement IList instead and return GmailContact's only.

See Also

GmailContactCollection Class | Johnvey.GmailAgent Namespace


GmailCookieFactory Class

Provides Gmail-specific cookie generation services.

For a list of all members of this type, see GmailCookieFactory Members.

System.Object
GmailCookieFactory

public class GmailCookieFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

GmailCookieFactory Members | Johnvey.GmailAgent Namespace


GmailCookieFactory Members

GmailCookieFactory overview

Public Instance Constructors

GmailCookieFactory Constructor Initializes a new instance of the GmailCookieFactory class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateCookie | Generates a Cookie for use with Gmail.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailCookieFactory Class | Johnvey.GmailAgent Namespace


GmailCookieFactory Constructor

Initializes a new instance of the GmailCookieFactory class.

public GmailCookieFactory();

See Also

GmailCookieFactory Class | Johnvey.GmailAgent Namespace


GmailCookieFactory Methods

The methods of the GmailCookieFactory class are listed below. For a complete list of GmailCookieFactory class members, see the GmailCookieFactory Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateCookie | Generates a Cookie for use with Gmail.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailCookieFactory Class | Johnvey.GmailAgent Namespace


GmailCookieFactory.GenerateCookie Method

Generates a Cookie for use with Gmail.

public Cookie GenerateCookie(
string cookieName
);

Parameters

cookieName
The name of the cookie to generate.

Return Value

The Cookie that can be sent along with a HttpWebRequest.

See Also

GmailCookieFactory Class | Johnvey.GmailAgent Namespace


GmailSession Class

Represents an in-use Gmail mailbox account.

For a list of all members of this type, see GmailSession Members.

System.Object
GmailSession

public class GmailSession

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

GmailSession Members | Johnvey.GmailAgent Namespace


GmailSession Members

GmailSession overview

Public Instance Constructors

GmailSession Constructor Initializes a new instance of the GmailSession class.

Public Instance Properties

CategoryCounts | Gets or sets the list of new message counts in all the user-defined categories.
Cookies | Gets or sets the cookie collection associated with the current session.
DefaultSearchCounts | Gets or sets the list of new message counts in each of the default searches: Inbox, All, Spam, Starred, Trash, Sent Items.
Fingerprint | Gets or sets the Gmail fingerprint.
HasConnectionError | Gets or sets the flag indicating a connection error with Gmail during the last request.
LastLoginTime | Gets or sets the last timestamp the user was authenticated with Google Accounts.
LastRefreshTime | Gets or sets the last timestamp when the mailbox status was refreshed.
Password | Gets or sets the user's Google Accounts password.
ThreadListTimestamp | Gets or sets the Gmail mailbox threadlist timestamp.
TotalMessages | Gets or sets the total number of messages in the mailbox.
UnreadThreads | Gets or sets the collection of unread threads.
Username | Gets or sets the user's Google Accounts username.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeUpdate | Signals the end of the session refresh and raises any appropriate events.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

NewMessageEventHandler Occurs when a new message has been received by the Gmail account.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnNewMessage | Occurs when a new message has been received by the Gmail account.

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession Constructor

Initializes a new instance of the GmailSession class.

public GmailSession();

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession Properties

The properties of the GmailSession class are listed below. For a complete list of GmailSession class members, see the GmailSession Members topic.

Public Instance Properties

CategoryCounts | Gets or sets the list of new message counts in all the user-defined categories.
Cookies | Gets or sets the cookie collection associated with the current session.
DefaultSearchCounts | Gets or sets the list of new message counts in each of the default searches: Inbox, All, Spam, Starred, Trash, Sent Items.
Fingerprint | Gets or sets the Gmail fingerprint.
HasConnectionError | Gets or sets the flag indicating a connection error with Gmail during the last request.
LastLoginTime | Gets or sets the last timestamp the user was authenticated with Google Accounts.
LastRefreshTime | Gets or sets the last timestamp when the mailbox status was refreshed.
Password | Gets or sets the user's Google Accounts password.
ThreadListTimestamp | Gets or sets the Gmail mailbox threadlist timestamp.
TotalMessages | Gets or sets the total number of messages in the mailbox.
UnreadThreads | Gets or sets the collection of unread threads.
Username | Gets or sets the user's Google Accounts username.

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.CategoryCounts Property

Gets or sets the list of new message counts in all the user-defined categories.

public System.Collections.SortedList CategoryCounts {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.Cookies Property

Gets or sets the cookie collection associated with the current session.

public System.Net.CookieCollection Cookies {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.DefaultSearchCounts Property

Gets or sets the list of new message counts in each of the default searches: Inbox, All, Spam, Starred, Trash, Sent Items.

public System.Collections.SortedList DefaultSearchCounts {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.Fingerprint Property

Gets or sets the Gmail fingerprint.

public string Fingerprint {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.HasConnectionError Property

Gets or sets the flag indicating a connection error with Gmail during the last request.

public bool HasConnectionError {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.LastLoginTime Property

Gets or sets the last timestamp the user was authenticated with Google Accounts.

public System.DateTime LastLoginTime {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.LastRefreshTime Property

Gets or sets the last timestamp when the mailbox status was refreshed.

public System.DateTime LastRefreshTime {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.Password Property

Gets or sets the user's Google Accounts password.

public string Password {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.ThreadListTimestamp Property

Gets or sets the Gmail mailbox threadlist timestamp.

public string ThreadListTimestamp {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.TotalMessages Property

Gets or sets the total number of messages in the mailbox.

public int TotalMessages {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.UnreadThreads Property

Gets or sets the collection of unread threads.

public GmailThreadCollection UnreadThreads {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.Username Property

Gets or sets the user's Google Accounts username.

public string Username {get; set;}

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession Methods

The methods of the GmailSession class are listed below. For a complete list of GmailSession class members, see the GmailSession Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FinalizeUpdate | Signals the end of the session refresh and raises any appropriate events.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnNewMessage | Occurs when a new message has been received by the Gmail account.

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.FinalizeUpdate Method

Signals the end of the session refresh and raises any appropriate events.

public void FinalizeUpdate();

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.OnNewMessage Method

Occurs when a new message has been received by the Gmail account.

protected virtual void OnNewMessage();

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession Events

The events of the GmailSession class are listed below. For a complete list of GmailSession class members, see the GmailSession Members topic.

Public Instance Events

NewMessageEventHandler Occurs when a new message has been received by the Gmail account.

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.NewMessageEventHandler Event

Occurs when a new message has been received by the Gmail account.

public event EventHandler NewMessageEventHandler;

See Also

GmailSession Class | Johnvey.GmailAgent Namespace


GmailSession.EventHandler Delegate

Default EventHandler for GmailSession events.

public delegate void GmailSession.EventHandler(
object sender
);

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

Johnvey.GmailAgent Namespace


GmailSessionCollection Class

Represents a collection of GmailSession objects.

For a list of all members of this type, see GmailSessionCollection Members.

System.Object
ArrayList
GmailSessionCollection

public class GmailSessionCollection : ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class currently inherits ArrayList, and therefore is not strongly typed. Ideally it should implement IList instead and return GmailSession's only.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

GmailSessionCollection Members | Johnvey.GmailAgent Namespace


GmailSessionCollection Members

GmailSessionCollection overview

Public Instance Constructors

GmailSessionCollection Constructor Initializes a new instance of the GmailSessionCollection class.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add (inherited from ArrayList) | Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailSessionCollection Class | Johnvey.GmailAgent Namespace


GmailSessionCollection Constructor

Initializes a new instance of the GmailSessionCollection class.

public GmailSessionCollection();

See Also

GmailSessionCollection Class | Johnvey.GmailAgent Namespace


GmailThread Class

Represents a Gmail conversation thread summary.

For a list of all members of this type, see GmailThread Members.

System.Object
GmailThread

public class GmailThread

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

GmailThread Members | Johnvey.GmailAgent Namespace


GmailThread Members

GmailThread overview

Public Instance Constructors

GmailThread Constructor Initializes a new instance of the GmailThread class.

Public Instance Properties

AttachHtml | Gets or sets the HTML-formatted 'thread has attachment' text (contains an IMG tag).
AuthorsHtml | Gets or sets the HTML-formatted thread author(s) text.
Categories | Gets or sets a list of zero or more categories in which the thread is classified.
DateHtml | Gets or sets the HTML-formatted thread date.
Flags | Gets or sets the flags string (unknown).
HasExtraSnippet | DEPRECATED: Gets or sets the flag indicating whether or not the thread has an extra snippet.
IsRead | Gets or sets the 'thread is read' flag.
IsStarred | Gets or sets the 'thread is starred' flag.
MatchingMessageID | Gets or sets the thread-message link identifier.
SnippetHtml | Gets or sets the thread snippet.
SubjectHtml | Gets or sets the thread subject.
ThreadID | Gets or sets the thread identifier.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread Constructor

Initializes a new instance of the GmailThread class.

public GmailThread();

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread Properties

The properties of the GmailThread class are listed below. For a complete list of GmailThread class members, see the GmailThread Members topic.

Public Instance Properties

AttachHtml | Gets or sets the HTML-formatted 'thread has attachment' text (contains an IMG tag).
AuthorsHtml | Gets or sets the HTML-formatted thread author(s) text.
Categories | Gets or sets a list of zero or more categories in which the thread is classified.
DateHtml | Gets or sets the HTML-formatted thread date.
Flags | Gets or sets the flags string (unknown).
HasExtraSnippet | DEPRECATED: Gets or sets the flag indicating whether or not the thread has an extra snippet.
IsRead | Gets or sets the 'thread is read' flag.
IsStarred | Gets or sets the 'thread is starred' flag.
MatchingMessageID | Gets or sets the thread-message link identifier.
SnippetHtml | Gets or sets the thread snippet.
SubjectHtml | Gets or sets the thread subject.
ThreadID | Gets or sets the thread identifier.

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.AttachHtml Property

Gets or sets the HTML-formatted 'thread has attachment' text (contains an IMG tag).

public string AttachHtml {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.AuthorsHtml Property

Gets or sets the HTML-formatted thread author(s) text.

public string AuthorsHtml {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.Categories Property

Gets or sets a list of zero or more categories in which the thread is classified.

public System.Collections.ArrayList Categories {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.DateHtml Property

Gets or sets the HTML-formatted thread date.

public string DateHtml {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.Flags Property

Gets or sets the flags string (unknown).

public string Flags {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.HasExtraSnippet Property

DEPRECATED: Gets or sets the flag indicating whether or not the thread has an extra snippet.

public bool HasExtraSnippet {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.IsRead Property

Gets or sets the 'thread is read' flag.

public bool IsRead {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.IsStarred Property

Gets or sets the 'thread is starred' flag.

public bool IsStarred {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.MatchingMessageID Property

Gets or sets the thread-message link identifier.

public string MatchingMessageID {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.SnippetHtml Property

Gets or sets the thread snippet.

public string SnippetHtml {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.SubjectHtml Property

Gets or sets the thread subject.

public string SubjectHtml {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThread.ThreadID Property

Gets or sets the thread identifier.

public string ThreadID {get; set;}

See Also

GmailThread Class | Johnvey.GmailAgent Namespace


GmailThreadCollection Class

Represents a collection of GmailThread objects.

For a list of all members of this type, see GmailThreadCollection Members.

System.Object
ArrayList
GmailThreadCollection

public class GmailThreadCollection : ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class currently inherits ArrayList, and therefore is not strongly typed. Ideally it should implement IList instead and return GmailThread's only.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

GmailThreadCollection Members | Johnvey.GmailAgent Namespace


GmailThreadCollection Members

GmailThreadCollection overview

Public Instance Constructors

GmailThreadCollection Constructor Initializes a new instance of the GmailThreadCollection class.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add (inherited from ArrayList) | Adds an object to the end of the ArrayList.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Inserts an element into the ArrayList at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailThreadCollection Class | Johnvey.GmailAgent Namespace


GmailThreadCollection Constructor

Initializes a new instance of the GmailThreadCollection class.

public GmailThreadCollection();

See Also

GmailThreadCollection Class | Johnvey.GmailAgent Namespace


Utilities Class

A collection of auxilliary tools used to deal with Gmail data.

For a list of all members of this type, see Utilities Members.

System.Object
Utilities

public class Utilities

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Johnvey.GmailAgent

Assembly: Johnvey.GmailAgent (in Johnvey.GmailAgent.dll)

See Also

Utilities Members | Johnvey.GmailAgent Namespace


Utilities Members

Utilities overview

Public Static Methods

CleanHtml | Removes HTML tags and decodes HTML entities.
ParseJSArray | Converts a string representation of a JavaScript array to an ArrayList() object.

Public Instance Constructors

Utilities Constructor Initializes a new instance of the Utilities class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Utilities Class | Johnvey.GmailAgent Namespace


Utilities Constructor

Initializes a new instance of the Utilities class.

public Utilities();

See Also

Utilities Class | Johnvey.GmailAgent Namespace


Utilities Methods

The methods of the Utilities class are listed below. For a complete list of Utilities class members, see the Utilities Members topic.

Public Static Methods

CleanHtml | Removes HTML tags and decodes HTML entities.
ParseJSArray | Converts a string representation of a JavaScript array to an ArrayList() object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Utilities Class | Johnvey.GmailAgent Namespace


Utilities.CleanHtml Method

Removes HTML tags and decodes HTML entities.

public static string CleanHtml(
string dirtyHtml
);

Parameters

dirtyHtml
The HTML string to clean.

Return Value

The cleansed string.

See Also

Utilities Class | Johnvey.GmailAgent Namespace


Utilities.ParseJSArray Method

Converts a string representation of a JavaScript array to an ArrayList() object.

public static ArrayList ParseJSArray(
string input
);

Parameters

input
String containing a JavaScript array.

Return Value

The converted ArrayList.

See Also

Utilities Class | Johnvey.GmailAgent Namespace